一个鸟人突然来了句他要在centos 5.2上装xfce,yum install xfce和yum install xfce4均没有合适的包(服务器没装x环境)
于是我ssh登录到服务器上看了下,的确没有
yum install xfce*感觉又有点过意不去,毕竟服务器也很老了,加上最进他又开了ftp服务
google之,答案几乎吐血,让在gnome环境下点添加/删除软件,然后点扩展包,点xfce4就OK了

于是man yum想看看有没有突破口
发现:
* groupinstall group1 [group2] [...]
* groupupdate group1 [group2] [...]
* grouplist [hidden]
* groupremove group1 [group2] [...]
* groupinfo group1 [...]
尝试性的
yum grouplist
列出centos安装时的软件分组,其中Available Groups代表未安装的分组:
Available Groups:
Tomboy
Cluster Storage
Office/Productivity
Engineering and Scientific
Beagle
GNOME Software Development
X Software Development
Virtualization
Legacy Network Server
DNS Name Server
GNOME Desktop Environment
XFCE-4.4
Base
FTP Server
Mono
Games and Entertainment
Clustering
Java
Java Development
OpenFabrics Enterprise Distribution
Emacs
X Window System
Graphics
Web Server
Ruby
Windows File Server
Printing Support
KDE Software Development
KDE (K Desktop Environment)
Horde
Sound and Video
PostgreSQL Database
News Server
Development Tools
FreeNX and NX
Graphical Internet
Done

发现有xfce分组,于是
yum groupinstall "XFCE-4.4"
大功告成

转自:http://hi.baidu.com/higaby/blog/item/a174e07f5cca3c3f0cd7dade.html